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1. INTRODUCTION

This document details the instructions necessary to install the SQL Server version of Simply Personnel. 

These instructions assume that the correct version of SQL Server is installed as well as all the latest service packs. The service packs are updates and bug fixes for the system. As of 09/01/2001 the latest service packs are sp5a for v6.5, sp4 for v7.0 and sp4 for SQL Server 2000. Simply Personnel was designed and tested using these and it will help to reduce the likelihood of problems if the installed versions are the same as these versions.

Simply Personnel will not run on SQL Server 7.0 with service pack two installed. Problems occur with database field names containing spaces. Microsoft confirmed this as an error and rectified it as of service pack 3.

2. Requirements

In order to perform the steps included in this document, the following things will be required:

· An installed and working version of SQL Server.

· The SQL scripts for the creation and initial population of the database.

· If upgrading an existing Simply Personnel database from Microsoft Access, make sure you have the upgrade.sql file (or upgrade2005.sql if using SQL Server 2005).

3. Creating The Database

3.1 SQL Server 7.0 / 2000

1. From the Start menu, select Programs -> Microsoft SQL Server -> Enterprise Manager.

2. Expand the SQL Server Group and the next branch (which should be the network name of the computer). Right click on the Database folder and select New Database.

3. Enter Personnel as the Name. A file will be created called Personnel_Data.MDF in the default location for the SQL Server data files. There is no need to change this unless the customer wishes to create the database in a different location. Leave all the other options as their default and make sure a file called Personnel_Log.LDF has been created on the Transaction Log tab. Again leave the location alone unless the customer wants it changed and leave the other options as their defaults.

4. Select OK to create the database. Right click on the Databases folder again and select Refresh. Expand the option to make sure the Personnel database has been created.

5. From the Tools menu, select SQL Query Analyzer. Make sure the drop down list on the menu of the window that appears reads Personnel. Insert the disk or CD containing the scripts into the drive and click on the File Open icon.

6. Locate the Person.sql script and execute it against the Personnel database.

7. If the database is a clean installation and not going to be a conversion from a Microsoft Access database, open the Default.sql script and execute it. Make sure that the only message that appears is “(1 row(s) affected)”, although it will appear several times.

8. Close the SQL Server Query Analyzer and return to the Enterprise Manager. Right click on the Users entry under the Personnel database and and enter the users that will be connecting to the Personnel database. These can either be individual domain users or a domain group.

9. Double click on the users or group entry and make sure all the options are selected.

10. Right click on the Security folder (this will be at the same level as the Databases folder) and left click on Logins and enter the users that will be connecting to the Personnel database. These can either be individual domain users or a domain group.
11. Select your users or your group and make sure that the public entry on the Server Roles tab is selected and that only the Personnel option on the Database Access tab is selected. Select OK.

3.2 SQL Server 2005

12. From the Start menu, select Programs -> Microsoft SQL Server 2005 -> SQL Server Management Studio. If the Connect to Server dialog appears, select the correct options for your SQL Server configuration and click on the Connect button.

13. On the tree on the right of the screen, right click on the Database folder and select New Database… to display the New Database window.

14. Enter Personnel as the Database name and click on the OK button.

15. Right click on the Databases folder again and select Refresh. Expand the option to make sure the Personnel database has been created.

16. Click on the File menu followed by Open  then File… to display the File Open dialog. Locate the Person.sql file and click on the Open button.

17. On the Connect to Database Engine window click on the Connect button.

18. On the toolbar change the drop down list from master to Personnel and then click on the Execute button. When completed the script will display the message 'Simply Personnel database script complete' and no errors should have been reported.

19. If the database is a clean installation and not going to be a conversion from a Microsoft Access database, open the Default.sql script and execute it in the same way as the previous script. Make sure that the only message that appears is “(1 row(s) affected)”, although it will appear several times.

20. Right click on the Security folder (this will be at the same level as the Databases folder) and left click on Logins and enter the users that will be connecting to the Personnel database. These can either be individual domain users or a domain group.

21. When adding the user or group make sure that the public entry on the Server Roles screen is selected and that only the Personnel option on the User Mapping screen is selected and that public and db_owner roles are selected. Select OK.

22. On the Management Studio tree, right click on the Security entry under the Personnel database and expand the Users branch and ensure the users that will be connecting to the Personnel database are present. These can either be individual domain users or a domain group.

If none of the Refresh options appear to work, the Management Studio and start it up again.

3.3 SQL Server Name

Before installing Simply Personnel on any client machines, make sure you know the name of the SQL Server that you will be connecting to. This will be the computer’s network name and can be found using the Network settings option in control panel.

4. Moving from MS Access to SQL database
4.1 SQL Server 7.0 / 2000

If you are upgrading an existing version of Simply Personnel from a Microsoft Access database to SQL Server make sure that the Access database is using the same version of Simply Personnel as the SQL Server database will be using. If Access currently used by an earlier version of Simply Personnel then it will need upgrading before the data is imported. Please contact the Simply Personnel help desk for instruction on how to do this.

If the Access database is used by a later version of Simply Personnel then you will not be able to import the data and should contact the Simply Personnel help desk on what you need to do.

If the Access database is using the same version of Simply Personnel as the SQL Server database then please do the following:

1. Run the ODBC Administrator and make sure that the Personnel data source is referencing the Access database you want the data importing from.

2. Run the SQL Server Enterprise Manager.

3. Expand the SQL Server Group, next branch (which should be the network name of the computer) and then the Databases folder.

4. Right click on the Personnel database and select All Tasks and then Import Data…
5. The DTS Import/Export Wizard window will open. Click on the Next button to go to the Choose a Data Source screen.

6. Change the Data Source to Other (ODBC Data Source) and the User/System DSN to Personnel.

7. Enter Personnel as the Username and enter the Password before clicking on the Next button to display the Choose a destination screen.

8. Leave the Destination as Microsoft OLE DB Provider for SQL Server and make sure the Database is set to Personnel. Click on the Next button to display the Specify Table Copy or Query screen.

9. Leave the selection as Copy table(s) and view(s) from the source database and click on the Next button to display the Select Source Tables and Views screen.

10. Click on the Select All button and make sure all the rows in the table have a green check mark next to them. Click on the Next button to display the Save, schedule, and replicate package screen.

11. Make sure the Run immediately option is checked and click on the Next button to display the Completing the DTS Import/Export Wizard screen. Click on the Finish button to import the data.

12. The Executing Package screen will appear to show the import progress. Once this has been done a message will appear saying ‘Successfully copied 118 table(s) from ACCESS to Microsoft SQL Server’. Click on the OK and then Done buttons.

13. From Enterprise Manager, select the Tools menu and the SQL Query Analyzer. Make sure the drop down list on the menu of the window that appears reads Personnel. Insert the disk or CD containing the scripts into the drive and click on the File Open icon.

14. Open the upgrade.sql script first and click on the Execute Query icon on the toolbar (the green arrow) to run the script. Expect to see the following messages:

(x row(s) affected)

(x row(s) affected)

(1 row(s) affected)

(1 row(s) affected)

(x row(s) affected)

The data import will now be complete.

4.2 SQL Server 2005

If you are upgrading an existing version of Simply Personnel from a Microsoft Access database to SQL Server make sure that the Access database is using the same version of Simply Personnel as the SQL Server database will be using. If Access currently used by an earlier version of Simply Personnel then it will need upgrading before the data is imported. Please contact the Simply Personnel help desk for instruction on how to do this.

If the Access database is used by a later version of Simply Personnel then you will not be able to import the data and should contact the Simply Personnel help desk on what you need to do.

If the Access database is using the same version of Simply Personnel as the SQL Server database then please do the following:

15. Run the ODBC Administrator and make sure that the Personnel data source is referencing the Access database you want the data importing from. Also make sure that the Personnel data source is configured as a System DSN and not a User DSN. If it isn’t then it will need to be changed.

16. Run the SQL Server Management Studio.

23. Click on the File menu followed by Open  then File… to display the File Open dialog. Locate the upgrade2005.sql file and click on the Open button.

24. On the Connect to Database Engine window click on the Connect button.

25. On the toolbar change the drop down list from master to Personnel and then click on the Execute button. When completed the script will display the message 'Simply Personnel SQL upgrade script complete' and no errors should have been reported.

5. ODBC Configuration

The ODBC configuration will be the same regardless of the version of SQL Server being used (with one exception for SQL Server 2000). Prior to configuring the ODBC, Simply Personnel must be installed from the CD. The installation will create two ODBC data sources (Personnel and PersonnelDemo) and this will both be configured for Microsoft Access drivers.

Once Simply Personnel has been installed, the computer will need to be rebooted. Reboot the machine and go to the ODBC Administrator in the Control Panel. Remove the Personnel data source and select the Drivers tab.

Please do not remove the PersonnelDemo datasource otherwise the Windows Installer program used to install Simply Personnel will reset the Simply Personnel ODBC configuration, restoring the Microsoft Access driver.
The version number of the SQL Server driver should begin with 3.70 (If you are using SQL Server 2000 then the drivers must be 2000.80.194.00 or above, these are only available from MDAC version 2.6 or above). If the version number is earlier than this then the ODBC drivers have not been upgraded correctly during the installation. To rectify this, run the mdac_typ.exe program located in the \Utilities directory on the CD. Don’t worry if the drivers are a later version.

Once the drivers have been upgraded, select Add to add a new data source. Select the SQL Server driver and click on Finish. On the next wizard, enter the Name Personnel and the Description Simply Personnel. The Server will be the name of the computer where SQL Server is installed. If installing Simply Personnel on the same machine as SQL Server then use the name “(local)” instead of the computer name.

Click on Next and select the “With Windows NT Authentication using the Network login ID” and select “Connect to SQL Server to obtain default settings for the additional configuration options”.
Click on Next and make sure the first drop down list reads Personnel. If it does not then there is probably a problem with the user configuration in SQL Server that needs to be rectified. Click Next again and then Finish. When the dialog appears click on Test Data Source. Various tests will be run and if everything has been configured correctly the message “TESTS COMPLETED SUCCESSFULLY!” will appear in the window. Click OK twice to save the settings.

Run Simply Personnel and log in as the ADMIN user. Enter the company’s licence details and the New Employee wizard will appear. Close Simply Personnel and move on to the next installation machine. Once the software has been installed and the ODBC been configured, logging in should not prompt you for the licence details if the data source is looking in the same place as the rest of the installed machines.

6. Database backups

Please Note that Simply Personnel do not take responsibility for the Personnel SQL Database backups that we recommend are run on the database. 

It is your responsibility to back the database up on a regular basis. A guide only on how to backup the database can be found on our knowledgebase here:

http://simplypersonnel.helpserve.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=156
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